Gradle构建springBoot项目

Gradle构建springBoot项目

你肯定会说为什么不用maven呢,我想说,要学就学自己不会的,这样才能会的更多,不是吗。

  1. 而且这边我是先创建的项目,然后增加的配置然后,引入springboot的依赖。
  2. 我的idea版本为2018.2,然后gradle版本必须为5.6以上才能构建,这里需要注意一下。
  3. 太高也不行,会和idea冲突,这里我们当然是需要选择,属于自己idea版本的Gradle。

下载如下

https://gradle.org/releases

配置加速

配置全局生效,和maven一样,单个项目配置,着实太麻烦。
找到 (用户家目录)/.gradle/init.gradle 文件,如果找不到 init.gradle 文件,自己新建一个
image.png

修改/添加 init.gradle 文件内的 repositories 配置

allprojects {
    repositories {
        maven {
            url "http://maven.aliyun.com/nexus/content/groups/public"
        }
    }
}

删除引入的依赖

这里本路径地址,比如引入失败之后,需要删除某个包。
~/.gradle/caches/modules-2/files-2.1

设置如下

image.png

创建主启动类

image.png

配置文件如下

plugins {
    id 'java'
    id 'org.springframework.boot' version '2.3.1.RELEASE'
    id 'io.spring.dependency-management' version '1.0.9.RELEASE'
}

group 'com.cxy'
version '1.0-SNAPSHOT'

sourceCompatibility = 1.8

repositories {
    mavenCentral()
}

dependencies {
    implementation 'org.springframework.boot:spring-boot-starter-data-elasticsearch'
    implementation 'org.springframework.boot:spring-boot-starter-web'
   

    testImplementation('org.springframework.boot:spring-boot-starter-test') {
        exclude group: 'org.junit.vintage', module: 'junit-vintage-engine'
    }
}

启动成功

这里我整合了es,学习中。码云地址
https://gitee.com/cuixiaoyan/elasticSearchAndJd